Enable AHCI sau khi đã cài Windows

Thảo luận trong 'Software - Kỹ thuật phần mềm' bắt đầu bởi HDNewbie, 30/5/09.

  1. dino

    dino Active Member

    Tham gia ngày:
    1/7/08
    Bài viết:
    2,061
    Đã được cảm ơn:
    21
    Nghề nghiệp:
    7 jobs
    Nơi ở:
    http://hdshop.tk
    Ðề: Enable AHCI sau khi đã cài Windows

    đã làm theo nhưng đến đoạn load windows là màn hình xanh, hic hic ...
     
  2. haovh_85

    haovh_85 Well-Known Member

    Tham gia ngày:
    17/6/09
    Bài viết:
    1,180
    Đã được cảm ơn:
    1,013
    Ðề: Enable AHCI sau khi đã cài Windows

    Đúng rồi. Một số máy khi làm theo cách này thì màn hình xanh. Mình cũng đã test Ok trên 1 số máy nhưng con máy của mình thì chịu vì trong Bios nó không có chế độ chuyển AHCI.
     
  3. NguyenHL

    NguyenHL New Member

    Tham gia ngày:
    11/6/09
    Bài viết:
    158
    Đã được cảm ơn:
    1
    Ðề: Enable AHCI sau khi đã cài Windows

    Hướng dẫn của HDNewbie chưa thật chi tiết. Cách này có thể không thành công trên một số mainboard. Tại sao? Điều nầy, tôi biết đc khi tìm cách enable AHCI vơi chipset AMD. Phần AHCI là một module trong chipset , Windows xem nó là một device. Mỗi Device có các thông số để nhận dạng. Thông số quan trọng nhất là:
    • Vendor ID
    • Device ID
    • Subsystem ID

    Trong hướng dẫn của HDNewbie phù hợp cho Device AHCI có thông số VEN_8086&DEV_3A22. Mình kiểm tra file iaAHCI.inf thì Device AHCI có 9 loại. Do đó trước khi chúng ta thực hiện phải kiểm tra thông số này để chỉnh sửa file AHCI.reg cho phù hợp với mainboard hiện có. tôi không có mainboard Intel nên tôi không thể hướng dẫn chi tiết cho a e được :)
     
    Chỉnh sửa cuối: 23/6/09
  4. dino

    dino Active Member

    Tham gia ngày:
    1/7/08
    Bài viết:
    2,061
    Đã được cảm ơn:
    21
    Nghề nghiệp:
    7 jobs
    Nơi ở:
    http://hdshop.tk
    Ðề: Enable AHCI sau khi đã cài Windows

    trong bios của mình có set IDE->AHCI nhưng màn hình vẫn xanh bác Bill :mad:
     
  5. kickball2006

    kickball2006 Active Member

    Tham gia ngày:
    6/9/08
    Bài viết:
    264
    Đã được cảm ơn:
    42
    Ðề: Enable AHCI sau khi đã cài Windows

    Mình cũng đang xài main như bạn, mong bạn post tutor sớm tí nhé.
    Thank
     
  6. giaothu

    giaothu Member

    Tham gia ngày:
    16/9/08
    Bài viết:
    48
    Đã được cảm ơn:
    0
    Ðề: Enable AHCI sau khi đã cài Windows

    Nếu khi khởi động báo lỗi các bác cần xem lại main của các bÁC chíp gì? ICH7R, ICH8R, ICH8DO...... Bằng cách dùng everet như sau: con của tôi là ICH9DO.

    [​IMG]



    rồi các bác mở file iaAHCI.inf trong file có dường dẫn như trong hình:


    [​IMG]

    Mở iaAHCI.inf bằng notepad rồi kéo thanh trượt để biết tương ứng với con chíp của mình thì cần sửa 3A22 trong file reg của bác chủ thớt bằng 4 ký hiệu nào nhớ sửa ở 2 chổ nhé? của tôi là 2922:

    [​IMG]

    Chúc các bác thành công!
     
    Chỉnh sửa cuối: 23/6/09
  7. NguyenHL

    NguyenHL New Member

    Tham gia ngày:
    11/6/09
    Bài viết:
    158
    Đã được cảm ơn:
    1
    Ðề: Enable AHCI sau khi đã cài Windows

    Chipset intel còn dễ vì file iaahci.inf có chú thích chi tiết. Do đó chúng ta có thể chỉnh sửa dễ dàng. Còn AMD thật sự là ác mộng.
     
  8. dino

    dino Active Member

    Tham gia ngày:
    1/7/08
    Bài viết:
    2,061
    Đã được cảm ơn:
    21
    Nghề nghiệp:
    7 jobs
    Nơi ở:
    http://hdshop.tk
    Ðề: Enable AHCI sau khi đã cài Windows

    mình xài ATI 690G mới đau, thôi chắc từ bỏ giấc mơ T___T
     
  9. NguyenHL

    NguyenHL New Member

    Tham gia ngày:
    11/6/09
    Bài viết:
    158
    Đã được cảm ơn:
    1
    Ðề: Enable AHCI sau khi đã cài Windows

    Đừng từ bỏ giấc mơ, mình đã làm đc. Hiện chưa rãnh viết tutorial cho a e tham khảo, mình cố gắng sớm thôi
     
  10. hbc

    hbc Moderator

    Tham gia ngày:
    16/5/09
    Bài viết:
    1,322
    Đã được cảm ơn:
    2,686
    Ðề: Enable AHCI sau khi đã cài Windows

    Bạn thử cách này xem : tải file sata controler đính kèm / giải nén/ chạy file install.cmd nó sẽ tự cài diver và cấu hình cho bạn (file chạy trên nhân của winnt)

    Không có sata thì hdd cua bạn chỉ là pata thôi, lúc copy file sẽ thấy sự khác biệt
     
  11. Haihard

    Haihard Member

    Tham gia ngày:
    19/12/08
    Bài viết:
    627
    Đã được cảm ơn:
    9
    Nghề nghiệp:
    Bánh đa cua
    Nơi ở:
    Việt Nam
    Ðề: Enable AHCI sau khi đã cài Windows

    Đính chính lại chút đi bạn của tôi.
     
  12. leecong

    leecong New Member

    Tham gia ngày:
    1/3/09
    Bài viết:
    15
    Đã được cảm ơn:
    5
    Ðề: Enable AHCI sau khi đã cài Windows

    cac bac theo huong dan duong link duoi day, co cau ten Khoa lam het roi, cuc ky don gian, khong phuc tap chi can biet enter la ok.

    http://3dvn.org/showthread.php?t=7832

    chuc vui
     
  13. mashima0905

    mashima0905 New Member

    Tham gia ngày:
    29/5/09
    Bài viết:
    6
    Đã được cảm ơn:
    1
    Ðề: Enable AHCI sau khi đã cài Windows

    AMD kuma7750 + Main Ha07ultra chipset 790gx thì enable seo hả mấy bác???
     
  14. hmt123

    hmt123 New Member

    Tham gia ngày:
    22/7/09
    Bài viết:
    1
    Đã được cảm ơn:
    1
    Ðề: Enable AHCI sau khi đã cài Windows

    đã thực hiện theo hướng dẫn và được kết quả như hình đính kèm (chip ich10r)
    nhưng tốc độ hình như vẫn như cũ, khởi động máy còn hiện màn hình chờ nhận sata device
    không biết có làm sai hoặc thiếu gì không ta
     
    Administrator cảm ơn bài này.
  15. havefun

    havefun New Member

    Tham gia ngày:
    31/3/09
    Bài viết:
    185
    Đã được cảm ơn:
    1
    Ðề: Enable AHCI sau khi đã cài Windows

    Của em nó lại hiện ra như thế này mới oái ăm (main Gigabyte EP45-UD3L, chipset ICH10R) :

    [​IMG]
     
  16. phuong210876

    phuong210876 New Member

    Tham gia ngày:
    29/1/09
    Bài viết:
    1,666
    Đã được cảm ơn:
    2
    Nơi ở:
    Hai Phong, Vietnam, Vietnam
    Ðề: Enable AHCI sau khi đã cài Windows

    Nói khoác tôi Vista ultimate 64Bit Sp2 thử bật AHCI không thèm cài màn hình nó xanh lè lun=))=))=))
     
  17. manhthang

    manhthang Huyền Thoại

    Tham gia ngày:
    28/10/08
    Bài viết:
    6,029
    Đã được cảm ơn:
    58
    Giới tính:
    Nam
    Ðề: Enable AHCI sau khi đã cài Windows

    Không tích hợp ICH10 vào bộ cài hoặc dùng riêng đĩa cài ICH10 thì cài Win bằng niềm tin bác ơi :cool:
     
  18. phuong210876

    phuong210876 New Member

    Tham gia ngày:
    29/1/09
    Bài viết:
    1,666
    Đã được cảm ơn:
    2
    Nơi ở:
    Hai Phong, Vietnam, Vietnam
    Ðề: Enable AHCI sau khi đã cài Windows

    thì đã nói là nói khoác mà ....................................... việc bật AHCI lên để cài win vista thì quá là đơn văn giản ý của chủ để TOPIC là cài WIN rỗi và muốn sử dụng AHCI thì phải làm thế này....

    Lần trước dùng main Giga EG45 làm phát được ngay mới đối con Asus p5q Pro turbo làm y chang mà không được bực quá
     
  19. xxc99

    xxc99 New Member

    Tham gia ngày:
    24/9/09
    Bài viết:
    86
    Đã được cảm ơn:
    2
    Ðề: Enable AHCI sau khi đã cài Windows


    Bac oi! em xai con gigabyte ga-m55plus-s3g. bac cho em xin driver zi bac lam on chi dum e enable ahci chi tiet di ah.cam on bac nhiu.please
     
  20. NguyenHL

    NguyenHL New Member

    Tham gia ngày:
    11/6/09
    Bài viết:
    158
    Đã được cảm ơn:
    1
    Ðề: Enable AHCI sau khi đã cài Windows

    Bac xin hướng dẫn ở topic http://hdvietnam.com/diendan/showthread.php?t=15702&highlight=ahci

    Bạn dùng patch nForce. Chúc bạn thành công.
     

Chia sẻ trang này